欢迎光临
我们一直在努力

CentOS升级Python27后,yum不可用

之前一篇文章介绍了《Centos6.8升级Python2.6为Python2.7》,升级完毕后通过pip安装依赖时不再提示版本过期,但是随之而来的问题就是yum不好使了,例如会出现如下报错

问题原因是因为yum不支持python2.7的版本,那么只需要在/usr/bin/yum中将第一行的#!/usr/bin/python更换为低版本即可。

原来的头部声明

更换以后的头部声明

这个python2.6怎么来的呢?

这里就会看到系统自带的以及我们升级后的python

按下esc,并且键入:wq即可保存修改。那么现在yum包管理器就好使了:

赞(0) 打赏
未经允许不得转载:码农志 » CentOS升级Python27后,yum不可用
分享到: 更多 (0)

评论 抢沙发

文章评论已关闭!

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏