念念不忘
必有回响

标签:Python

Python3安装mysql-connector-码农志
编程不止

Python3安装mysql-connector

阅读(927)赞(0)

由于现在大部分流行框架都已经逐渐支持Python3,这也算是趋势吧,于是将Python2的系统提前兼容到Python3很有必要,在改造过程中,发现mysql-connector这个模块无法现在,提示ModuleNotFoundError: ...

CentOS升级Python27后,yum不可用-码农志
运维不息

CentOS升级Python27后,yum不可用

阅读(1603)赞(0)

之前一篇文章介绍了《Centos6.8升级Python2.6为Python2.7》,升级完毕后通过pip安装依赖时不再提示版本过期,但是随之而来的问题就是yum不好使了,例如会出现如下报错 [root@tvzr ~]# yum search...

CentOS6.8升级Python2.6为Python2.7-码农志
运维不息

CentOS6.8升级Python2.6为Python2.7

阅读(1589)赞(0)

默认的Centos的Python版本为2.6,使用pip的时候经常提示Python2.6已过期,那么还是升级到Python2.7吧。 1. 下载文件并解压 wget https://www.python.org/ftp/python/2.7...